1° Forum di Astronomia Amatoriale Italiano

Il primo forum di astrofili per astrofili, nato nel 2000.
Oggi è lunedì 18 ottobre 2021, 11:27

Menu

* Home
* Iscriviti
* La Bacheca
* F.A.Q.
* Cerca
* Login/Logout 

Login

Nome utente:
Password:

 Ho dimenticato la password

In Linea

Visitano il forum: Bing [Bot] e 18 ospiti

Regolamento

regolamento

Links

*
Astrocafè

Segnala bolide
* Meteoblue.com
* Previsioni seeing
* Il Meteo.it
Help Forum
 

Tutti gli orari sono UTC + 1 ora




Apri un nuovo argomento Rispondi all’argomento  [ 295 messaggi ]  Vai alla pagina Precedente  1 ... 24, 25, 26, 27, 28, 29, 30  Prossimo
Autore Messaggio
MessaggioInviato: lunedì 11 gennaio 2021, 14:42 

Iscritto il: giovedì 12 marzo 2015, 22:14
Messaggi: 117
Nagual ha scritto:
Buongiorno a tutti, scrivo per un problema che ho riscontrato con il tool di allineamento di ekos.
In pratica quando vado a fare il platesolving con la funzione go-to il risolutore da esito positivo individuando l'errore rispetto alla Stella puntata ma poi non avviene nessun movimento apprezzabile della montatura e la seguente iterazione da risultati simili alla precedente. In pratica sembra che non arrivino i comandi alla montatura (heq5 connessa mediante cavo tra pc e pulsantiera synscan). Ho pensato potesse essere un problema di cablaggio dato che è effettuato mediante due cavi, uno USB-seriale e poi seriale ingresso pulsantiera, però quando utilizzo il comando go-to sul planetario la montatura si muove correttamente...
Qualcuno ha qualche consiglio da darmi?
Grazie
Matteo


Nel caso potesse tornare utile ad altri il problema stava proprio nella connessione alla montatura tramite pulsantiera synscan (con apposito driver selezionabile da pannello di controllo) che evidentemente non faceva arrivare alla montatura gli impulsi per la correzione in AR e DEC a seguito del plate solving.
Per ovviare al problema ho impostato la montatura nella modalità "pc direct mode" e, utilizzando i driver eqmod, tutto pare funzionare correttamente.

Saluti
Matteo


Top
  Profilo    
 
MessaggioInviato: lunedì 11 gennaio 2021, 20:03 

Iscritto il: lunedì 30 aprile 2018, 12:27
Messaggi: 84
Località: Sorrento
Tipo di Astrofilo: Fotografo
Nagual ha scritto:
Nagual ha scritto:
Buongiorno a tutti, scrivo per un problema che ho riscontrato con il tool di allineamento di ekos.
In pratica quando vado a fare il platesolving con la funzione go-to il risolutore da esito positivo individuando l'errore rispetto alla Stella puntata ma poi non avviene nessun movimento apprezzabile della montatura e la seguente iterazione da risultati simili alla precedente. In pratica sembra che non arrivino i comandi alla montatura (heq5 connessa mediante cavo tra pc e pulsantiera synscan). Ho pensato potesse essere un problema di cablaggio dato che è effettuato mediante due cavi, uno USB-seriale e poi seriale ingresso pulsantiera, però quando utilizzo il comando go-to sul planetario la montatura si muove correttamente...
Qualcuno ha qualche consiglio da darmi?
Grazie
Matteo


Nel caso potesse tornare utile ad altri il problema stava proprio nella connessione alla montatura tramite pulsantiera synscan (con apposito driver selezionabile da pannello di controllo) che evidentemente non faceva arrivare alla montatura gli impulsi per la correzione in AR e DEC a seguito del plate solving.
Per ovviare al problema ho impostato la montatura nella modalità "pc direct mode" e, utilizzando i driver eqmod, tutto pare funzionare correttamente.

Saluti
Matteo


Ciao Matteo,
grazie per aver condiviso la soluzione di questo problema

Saluti
Francesco


Top
  Profilo    
 
MessaggioInviato: mercoledì 3 febbraio 2021, 16:41 

Iscritto il: domenica 26 aprile 2020, 18:00
Messaggi: 7
Tipo di Astrofilo: Visualista e Fotografo
Ciao, ho appena ricevuto un pi 400, collegato a monitor esterno e ora funziona tutto.
Però ho un problema, e una domanda...

Problema, quando parte mi dice che NON esiste nessun modulo wi-fi (che ovviamente il pi 400 invece ha).
Domanda, ho preso un gps usb, non c'è modo di farlo vedere a ekos/kstars?

Grazie.


Top
  Profilo    
 
MessaggioInviato: venerdì 5 febbraio 2021, 21:24 

Iscritto il: giovedì 12 marzo 2015, 22:14
Messaggi: 117
Buonasera a tutti, qualcuno utilizza l'astrofocus sull'AstroPI?
Io ho provato ma, una volta collegato al raspberry e lanciato ekos, seppure viene riconosciuto, non da cenni di vita
In motore non si muove e il driver non mi da la possibilità di impostare nessun parametro.
Ho provato a verificare se l'HW funziona tramite invio manuale da porta seriale dei comandi e inizialmente non funzionava, poi ho cambiato simbolo di fine comando (visto che sembrava non vedere l'invio) cambiando (Serial.read() == '\n') con (Serial.read() == 'f') e da seriale il motore funziona correttamente. Il problema rimane però una volt che lo attacco al raspberry...
Potrebbe esser un problema di driver indi?


Top
  Profilo    
 
MessaggioInviato: venerdì 5 febbraio 2021, 21:42 

Iscritto il: lunedì 30 aprile 2018, 12:27
Messaggi: 84
Località: Sorrento
Tipo di Astrofilo: Fotografo
woo65 ha scritto:
Ciao, ho appena ricevuto un pi 400, collegato a monitor esterno e ora funziona tutto.
Però ho un problema, e una domanda...

Problema, quando parte mi dice che NON esiste nessun modulo wi-fi (che ovviamente il pi 400 invece ha).
Domanda, ho preso un gps usb, non c'è modo di farlo vedere a ekos/kstars?

Grazie.


Ciao,
proverei a fare un upgrade del sistema con "sudo apt-get update" e "sudo apt-get upgrade".
Poi dal menù accedere alle impostazioni oppure da shell con "sudo raspi-config" e controllare le eventuali periferica disattivate.
Per il gps bisogna controllare se è presente nell'elenco e se qualcuno (su GitHub o sul forum INDI) ha creato un driver.

Nagual ha scritto:

Buonasera a tutti, qualcuno utilizza l'astrofocus sull'AstroPI?
Io ho provato ma, una volta collegato al raspberry e lanciato ekos, seppure viene riconosciuto, non da cenni di vita
In motore non si muove e il driver non mi da la possibilità di impostare nessun parametro.
Ho provato a verificare se l'HW funziona tramite invio manuale da porta seriale dei comandi e inizialmente non funzionava, poi ho cambiato simbolo di fine comando (visto che sembrava non vedere l'invio) cambiando (Serial.read() == '\n') con (Serial.read() == 'f') e da seriale il motore funziona correttamente. Il problema rimane però una volt che lo attacco al raspberry...
Potrebbe esser un problema di driver indi?


probabilmente non è il driver adatto, cmq puoi dare un'occhiata al codice per vedere cosa combina, lo trovi in "home/pi/indi-****" dove al posto degli asterischi va il driver che selezioni da kstars.
Dopo ogni modifica va ricompilato:

cd build
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
make
sudo make install

Saluti
Francesco


Top
  Profilo    
 
MessaggioInviato: lunedì 8 febbraio 2021, 10:44 

Iscritto il: martedì 7 aprile 2009, 12:52
Messaggi: 32
Località: Roma
Tipo di Astrofilo: Visualista aspirante Fotografo
Salve, intanto vorrei ringraziare tutti per l'importante lavoro che state svolgendo!!!
Dopo anni di lontananza dai cieli, ho finalmente riesumato il mio C8 e VOI mi avete convinto ad utilizzare il mio raspberry pi 4 per gestire un po' di cose.

Volevo costruire un focuser che sia perfettamente compatibile con questa distro, ho girato tra mille progetti ed alla fine ho optato per chiedere consiglio a voi, l'hardware già in mio possesso (oltre al C8):

- stepper motor 28BYJ-48 con 2048 steps per revolution
- motor driver ULN2003A
- arduini vari

Lo scopo è quello di poter focheggiare sia via rasperry sia in manuale con due pulsanti hardware (per le osservazioni visuali).

Potreste suggerirmi quale, secondo voi, potrebbe essere un buon progetto da associare ad AstroPI.

Grazie a tutti


Top
  Profilo    
 
MessaggioInviato: lunedì 8 febbraio 2021, 12:12 
Avatar utente

Iscritto il: mercoledì 9 maggio 2012, 13:59
Messaggi: 1777
Località: Provincia di Sondrio
C'è l'astrofocus del buon Ivaldo, che però nelle ultime versioni ha purtroppo perso i tasti per l'uso in manuale senza pc, ma forse il buon Simone Martina, che ne è esperto, sa come ripristinare la funzione.
viewtopic.php?f=15&t=98600

Un progetto che mi pare molto buono è il PnP Focus che può essere gestito da tastierino. Non so se i tuoi motorshield ed arduino possano andare bene, lascio controllare a te. Il vantaggio del PNP Focus è dato anche dal fatto che usa il protocollo del focheggiatore Moonlite per comunicare con il pc, quindi usa i driver ascom ed Indi già esistenti per il diffusissimo focheggiatore.
https://www.cloudynights.com/topic/5946 ... ontroller/
https://github.com/aruangra/PnP-Focus

Io non ho fatto nessuno dei due, ti do solo la mia opinione da quello che ho letto dai relativi thread dei progetti.

Ciao

_________________
ES ULD 16' Gen II
Vixen A70Lf su Porta Mini
APM XWA 100° 20, 13, 9, 7, 5, 3.5
ES 82° 30, 18, 11
PLOSSL Vixen 20 6,3 Tecnosky 9
ES UHC OIII e ND variabile da 2"
Radiant SQML GSO Coma Corr.


Top
  Profilo    
 
MessaggioInviato: lunedì 8 febbraio 2021, 13:56 

Iscritto il: giovedì 12 marzo 2015, 22:14
Messaggi: 117
dagno ha scritto:
Salve, intanto vorrei ringraziare tutti per l'importante lavoro che state svolgendo!!!
Dopo anni di lontananza dai cieli, ho finalmente riesumato il mio C8 e VOI mi avete convinto ad utilizzare il mio raspberry pi 4 per gestire un po' di cose.

Volevo costruire un focuser che sia perfettamente compatibile con questa distro, ho girato tra mille progetti ed alla fine ho optato per chiedere consiglio a voi, l'hardware già in mio possesso (oltre al C8):

- stepper motor 28BYJ-48 con 2048 steps per revolution
- motor driver ULN2003A
- arduini vari

Lo scopo è quello di poter focheggiare sia via rasperry sia in manuale con due pulsanti hardware (per le osservazioni visuali).

Potreste suggerirmi quale, secondo voi, potrebbe essere un buon progetto da associare ad AstroPI.

Grazie a tutti


Io ho provato ad utilizzare l'Astrofocus sul Raspberry ma senza risultati, non so se si tratta di un problema con il driver indi o con il mio hw.
Adesso voglio provare con un clone Moonlite che, come ti hanno già scritto, non ha problemi di driver (dal momento che usa quelli dei focheggiatori originali).
Io mi stavo basando su questo progetto:
https://github.com/Hansastro/Focuser

Adesso sono in attesa della schedina A4988 e poi provo a vedere se va.
Vi tengo aggiornati!


Top
  Profilo    
 
MessaggioInviato: lunedì 8 febbraio 2021, 14:24 

Iscritto il: martedì 7 aprile 2009, 12:52
Messaggi: 32
Località: Roma
Tipo di Astrofilo: Visualista aspirante Fotografo
Cita:
Il vantaggio del PNP Focus è dato anche dal fatto che usa il protocollo del focheggiatore Moonlite per comunicare con il pc, quindi usa i driver ascom ed Indi già esistenti per il diffusissimo focheggiatore.


Cita:
Adesso voglio provare con un clone Moonlite che, come ti hanno già scritto, non ha problemi di driver (dal momento che usa quelli dei focheggiatori originali).
Io mi stavo basando su questo progetto:
https://github.com/Hansastro/Focuser


Grazie ad entrambi per le risposte,
in merito al moonlite ho trovato anche questo semplice clone (che fatalmenta utilizza già l'hardware in mio possesso)

https://lospantalones.org/diy-auto-focu ... ite-clone/

L'unico problema è che anche qui niente pulsanti ed io non sono abbastanza dentro per aggiungerli, per cui stavo valutando il progetto originale ma vorrei sapere se secondo voi è compatibile con la distro

https://github.com/EverettQuebral/EQFocuser

Che ne dite?

Grazie


Top
  Profilo    
 
MessaggioInviato: lunedì 8 febbraio 2021, 19:27 
Avatar utente

Iscritto il: mercoledì 9 maggio 2012, 13:59
Messaggi: 1777
Località: Provincia di Sondrio
Se ti va di leggere il thread del PnP se non ricordo male si potevano usare alcuni hardware alternativi, ma non sono certo di ricordare bene...

_________________
ES ULD 16' Gen II
Vixen A70Lf su Porta Mini
APM XWA 100° 20, 13, 9, 7, 5, 3.5
ES 82° 30, 18, 11
PLOSSL Vixen 20 6,3 Tecnosky 9
ES UHC OIII e ND variabile da 2"
Radiant SQML GSO Coma Corr.


Top
  Profilo    
 
Visualizza ultimi messaggi:  Ordina per  
Apri un nuovo argomento Rispondi all’argomento  [ 295 messaggi ]  Vai alla pagina Precedente  1 ... 24, 25, 26, 27, 28, 29, 30  Prossimo

Tutti gli orari sono UTC + 1 ora


Chi c’è in linea

Visitano il forum: Bing [Bot] e 18 ospiti


Non puoi aprire nuovi argomenti
Non puoi rispondere negli argomenti
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi inviare allegati

Cerca per:
Vai a:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Traduzione Italiana phpBBItalia.net basata su phpBB.it 2010